• <tt id="gi6my"><input id="gi6my"></input></tt>
  • <samp id="gi6my"><label id="gi6my"></label></samp>
  • <div id="gi6my"></div>
    <table id="gi6my"><bdo id="gi6my"></bdo></table>
    当前位置:主页 > 技术支持 > 技术资料 >
    技术资料

    三层交换机实现不同VLAN间通信(实例分析)

    时间:2018-09-17 来源:njqg.net浏览次数:52

     

    一、案例要求:

    若企业中有2个部门:销售部和技术部(2个部门PC机IP地址在不同网段),其中销售部的PC机分散连接在2台交换机上,配置交换机使得销售部PC能够实现相互通信,而且销售部和技术部之间也能相互通信。

    在本实验中,我们将PC1和PC3分别连接到SwitchA(三层交换机)的F0/5端口和SwitchB的F0/5端口并划入VLAN 10,将PC2连接到SwitchA(三层交换机)的F0/15端口并划入VLAN 20,SwitchA和SwitchB之间通过各自的F0/24端口连接。配置三层交换机使在不同VLAN组中的PC1、PC2、PC3能相互通信。

     

    二、拓扑图

    S3550-24(三层交换机)1台、S2126交换机1台、PC机3台。

     

    VLAN间通信实验拓扑结构图

    VLAN间通信实验拓扑结构图

     

    三、配置步骤

    1.按实验拓扑连接设备,并按图中所示配置PC机的IP地址,PC1、PC3网段相同可以通信,但是PC1、PC3和PC2是不同网段的,所以PC2(技术部)不能和另外2台PC机(销售部)通信。

     

    2.在交换机SwitchA上创建VLAN 10,并将0/5端口划入VLAN 10中。

    SwitchA(config)#vlan 10           !创建VLAN 10

    SwitchA (config-vlan)#name sales    ! 将VLAN 10 命名为sales

    SwitchA (config)#interface f0/5      !进入F0/5接口配置模式

    SwitchA (config-if)#switchport access vlan10    !将F0/5端口划入VLAN 10

    SwitchA #show vlan id 10     !验证已创建了VLAN 10并已将F0/5端口划入VLAN 10中。

     

    代码小结:

    创建vlan为 10
    将vlan10命名为 sales(销售部)
    划分的端口为 F0/5

     

    3.在交换机SwitchA上创建VLAN 20,并将F0/15口划分到VLAN 20中。

    SwitchA(config)#vlan20            !创建VLAN 20

    SwitchA(config-vlan)#name technical     ! 将VLAN 20 命名为technical

    SwitchA(config)#interface f0/15       !进入F0/15接口配置模式

    SwitchA(config-if)#switchport access vlan 20    !将F0/15端口划入VLAN 20

    SwitchA #showvlan id 20    !验证已创建了VLAN 20并已将F0/15端口划入VLAN 20中。

     

     代码小结:

    创建vlan为 20
    将vlan10命名为 technical(技术部)
    划分的端口为 F0/15
     

     

    4.在交换机SwitchA上与SwitchB相连的端口(此处为F0/24端口)定义为tag vlan 模式。

     

    SwitchA (config)#interface f0/24             !进入接口配置模式

    SwitchA (config-if)#switchport mode trunk     !将F0/24口设置为tag vlan模式

    SwitchA (config)#show interfaces f0/24 switch  !验证F0/24口已被设置为tag vlan模式

     

     

    5.在交换机SwitchB上创建VLAN 10,并将F0/5端口划入VLAN 10中。

    SwitchB(config)#vlan 10           !创建VLAN 10

    SwitchB (config-vlan)#name sales    ! 将VLAN 10 命名为sales

    SwitchB (config)#interface f0/5      !进入F0/5接口配置模式

    SwitchB (config-if)#switchport access vlan10    !将F0/5端口划入VLAN 10

    SwitchB #show vlan id 10 !验证已创建了VLAN 10并已将F0/5端口划入VLAN 10中

     

     

    6.在交换机SwitchB上与SwitchA相连的端口(此处为F0/24端口)定义为tag vlan 模式。

     

    SwitchB (config)#interface f0/24             !进入接口配置模式

    SwitchB (config-if)#switchport mode trunk     !将F0/24口设置为tag vlan模式

    SwitchB (config)#show interfaces f0/24 switch  !验证F0/24口已被设置为tag vlan模式。

     

    7.设置三层交换机VLAN 间通讯

       开启三层交换机的路由功能

    SwitchA>enable

    SwitchA#configure terminal

    SwitchA(config)#ip routing          !开启三层交换机的路由功能

     

    SwitchA(config) #interface vlan 10     ! 创建虚拟接口vlan10

    SwitchA(config-if) #ip address 192.168.10.254 255.255.255.0  ! 配置vlan10的虚拟接口ip地址

    SwitchA(config) #interface vlan 20     !创建虚拟接口vlan20! 配置vlan20的虚拟接口ip地址

    SwitchA(config-if) #ip address 192.168.20.254 255.255.255.0  ! 配置vlan20的虚拟接口ip地址

     

    8.将PC1和PC3的默认网关设置为192.168.10.254,将PC2的默认网关设置为192.168.20.254

     

    9.验证PC1、PC2与PC3能相互ping通。

    C:\ >ping 192.168.20.1    !从PC1上ping  PC2

    C:\ >ping 192.168.20.1    !从PC3上ping  PC2

    C:\>ping 192.168.10.2    !从PC2上ping  PC3

     

     

     

    附:三层交换机基本配置:

    1.开启三层交换机的路由功能

    SwitchA>enable

    SwitchA#configure terminal

    SwitchA(config)#ip routing                               !开启三层交换机的路由功能

    2.配置三层交换机端口的路由功能

    SwitchA(config)# interface fastethernet0/5

    SwitchA(config-if)#noswitchport                          !开启端口的三层路由功能

    SwitchA(config-if)#ip address 192.168.1.5255.255.255.0       !给端口配置ip地址

    SwitchA(config-if)#no shutdown

    SwitchA(config-if)#end

    3.验证,测试配置

    SwitchA#show ip interface                                  !查看接口状态信息

    (Operstatus 状态是up)

    SwitchA#show interface f0/5                                 !查看接口状态信息(Adminstatus状态是up)

    本文标签:
    ?
    久久窝窝国产精品午夜看片_欧美大香线蕉线伊人久久_久久伊人成色777综合网_极品人妻的娇喘呻吟